6 Antworten Neueste Antwort am 06.12.2016 13:24 von chrisocki

    Fehler bei der Umstellung mittels Server-Anpassungs-Assistent

    svenboerner Beginner

      Hallo,

       

      nach dem Kopieren der WINDVSW1,2,3 Verzeichnisse sowie der Lizenzpoolinformation auf einen neuen Server und anschleßender Freigabe möchte ich den Server-Anpassungs-Assistent nutzen (bzw. ist dieser aufgrund der mehreren Datenpfade erforderlich).

       

      Der Assistent selbst läuft korrekt durch, findet noch zwei Datenpfade welche ich auschließe, anschließend trägt er die Infos in die Config-Datenbank ein und stellt SUT.exe bereit.

       

      Laut der Checkliste (https://www.datev.de/dnlexom/client/app/index.html#/document/1011814) muss dann einmalig "sut.exe /s=Zielservername /g" ausgeführt werden. Dies führt nach einer gewissen Ausführungszeit von einigen Sekunden zu dem Fehler "Falscher Parameter". Der Assistent kann nur geschlossen werden. Nach nochmaligem Erstellen der Konfiguration und anschließendem Ausführen ohne den Parameter "/g" erhält man das gleiche Ergebnis.

       

      Leider weiß ich an dieser Stelle nicht weiter.

       

      Kann hier ggf. jemand helfen?

       

      Danke vorab!

      • 0. Re: Fehler bei der Umstellung mittels Server-Anpassungs-Assistent
        svenboerner Beginner

        Ja das kann natürlich möglich sein, grundsätzlich wird es aber unterstützt und sicherlich auch bei der ein oder anderen Übernahme so umgesetzt. Einen Einfluss darauf hatte ich leider nicht.

         

        Durch das Log bin ich in der Lage gewesen die eigentliche Ursache (Komponente Installationsmanager) zu ermitteln und dann die Pfade dort manuell zu korrigieren, so dass der Assistenz schlussendlich durchlief.

        • Alle Antworten
          • 1. Re: Fehler bei der Umstellung mittels Server-Anpassungs-Assistent
            jan Aufsteiger

            Am neuen DATEV Fileserver wurden die WINDVSW1,2,3 Freigaben bereitgestellt?

            Am alten DATEV Fileserver wurde die WINDVSW1,2,3 Freigaben beendet?

            Am WTS / Arbeitsplatz wurde das Netzlauwerk mit dem neuen DATEV Fileserver verbunden?

            Die SUT.exe wird an einem WTS / Arbeitsplatz gestartet und nicht am neuen / alten DATEV Fileserver?

            "Zielservername" wurde durch den korrekten Namen des neuen DATEV Fileservers ersetzt?

            Die SUT.exe wurde einmal auf ein lokales Laufwerk am WTS / Arbeitsplatz kopiert und die CMD zum Aufruf der SUT.exe wurde als Administrator ausgeführt?

            SUT.exe /s=Server /g auch mal von Hand in die CMD getippt? Nicht das beim Copy&Paste irgendein verwurstetes Zeichen mitkommt?

             

            Am 15.11 wurde der Punkt 8 editiert.. Ich bin grade unsicher, ob der Parameter /g schon immer da war, oder man da "früher" einen anderen brauchte?!

            • 2. Re: Fehler bei der Umstellung mittels Server-Anpassungs-Assistent
              svenboerner Beginner

              Erstmal vielen Dank für die Antwort!

               

              Ja die Punkte habe ich alle so durchgeführt. Der Paramter /g hat mich auch verunsichert, da in allen anderen Dokumenten nicht aufgeführt.

               

              Ich kann ja die Umstellungskonfiguration wieder löschen und neu erstellen und anschließend auch wieder SUT ausführen. Egal ob mit /g oder ohne, es kommt das gleiche Ergebnis raus.

               

              In der configdb (Ordner) am neuen Server wird auch unter /configdb/SUT eine SRV_MOVE.txt erstellt. Diese endet hiermit:

               

              > 19:55:08:  CMoveIniExtensions

              < 19:55:08:  CMoveIniExtensions

              beendet   am : 03-Dec-2016   um : 19:55 Uhr

               

              ein paar Zeilen weiter oben steht folgendes:

              19:55:02:  Component: <B0000047>

              19:55:02:       Ext-Interface:  <noname> Loaded from SUT-Resource for INSTMAN

              19:55:02:       Category: <INI>

              19:55:02:       ObjectAddress:  [%DATAPATH%\CDPfade.ini]

               

              Ich vermute, es gibt einen Fehler bei der Umstellung der Komponente B0000047.

              Geändert am 03.12.16 um 20:14 Uhr
              • 3. Re: Fehler bei der Umstellung mittels Server-Anpassungs-Assistent
                jan Aufsteiger

                Das hilft jetzt nicht wirklich weiter:

                 

                Ich bin mir nicht komplett sicher, aber ich meine es wird (mittlerweile / bzw. wurde noch nie wirklich empfohlen) davon abgeraten, mehrere WinDVSW pro Server zu haben.

                https://www.datev.de/dnlexom/client/app/index.html#/document/1080171?hitMarkTerms%5B%5D=windvsw&hitMarkTerms%5B%5D=Windv…

                 

                Das sollte aber nichts mit dem SAA Problem zu tun haben, da der ja nur "stumpf" im vorhandenen sucht und ersetzt.

                • 4. Re: Fehler bei der Umstellung mittels Server-Anpassungs-Assistent
                  svenboerner Beginner

                  Ja das kann natürlich möglich sein, grundsätzlich wird es aber unterstützt und sicherlich auch bei der ein oder anderen Übernahme so umgesetzt. Einen Einfluss darauf hatte ich leider nicht.

                   

                  Durch das Log bin ich in der Lage gewesen die eigentliche Ursache (Komponente Installationsmanager) zu ermitteln und dann die Pfade dort manuell zu korrigieren, so dass der Assistenz schlussendlich durchlief.

                  • 5. Re: Fehler bei der Umstellung mittels Server-Anpassungs-Assistent
                    jan Aufsteiger

                    Wunderbar, dass es geklappt hat.

                     

                    Es wird _noch_ unterstützt, meine ich Ich habe die Infos dazu grade nicht im Kopf und bin die nächste Zeit nicht im Büro. Ich gucke aber mal nach, wenn ich wieder an die Sachen rankomme.

                    Vermutlich wird das aber wie ein Peer2Peer Netz und nie abgekündigt und immer mitgeschleppt.

                    • 6. Re: Fehler bei der Umstellung mittels Server-Anpassungs-Assistent
                      chrisocki Aufsteiger

                      Korrekt, diese "Multi-Daten-Töpfe" werden noch unterstützt.

                       

                      Diese Unterstützung wird von DATEV "geduldet". Bereits Anfang 2015 wurde die Empfehlung seitens DATEV an die Systempartner herausgegeben, diese Umgebungen NICHT weiter einzurichten.

                       

                      Mit DVD 10.1 orange Lampe / ab DVD 11.0 orange Lampe + explizite Bestätigung durch Benutzer während des Updates / ab DVD 12.0 rote Lampe und Installation wird abgebrochen.

                       

                      Diese Informationen gab es auf dem Admin-Workshop. Die Kollegen(innen) die den Workshop besuchen, wissen wo Sie das entsprechende Dokument hierzu finden.

                       

                      Grüße

                      Chr.Ockenfels

                      3 von 3 Personen fanden dies hilfreich